LISTSERV mailing list manager LISTSERV 16.0

Help for MODS Archives


MODS Archives

MODS Archives


MODS@LISTSERV.LOC.GOV


View:

Message:

[

First

|

Previous

|

Next

|

Last

]

By Topic:

[

First

|

Previous

|

Next

|

Last

]

By Author:

[

First

|

Previous

|

Next

|

Last

]

Font:

Proportional Font

LISTSERV Archives

LISTSERV Archives

MODS Home

MODS Home

MODS  November 2018

MODS November 2018

Subject:

MADS XSLT error - Cannot add attributes to an element

From:

Linda Jansova <[log in to unmask]>

Reply-To:

Metadata Object Description Schema List <[log in to unmask]>

Date:

Mon, 5 Nov 2018 21:44:35 +0100

Content-Type:

multipart/mixed

Parts/Attachments:

Parts/Attachments

text/plain (49 lines) , americke_romany.xml (50 lines)

Dear all,

I have recently been working with MARCXML to MADS stylesheet
(http://www.loc.gov/standards/marcxml/xslt/MARC21slim2MADS.xsl) as this
stylesheet has become an integral part of the latest versions of
Evergreen ILS and is now used during authority records processing.

I have encountered an error while trying to transform MARCXML genre/form
authority records from the National Library of the Czech Republic. An
example of such a record is attached. (The 755 field uses zero as the
first indicator which is not compliant with MARC specs but even if the
indicator is changed to nothing/space, the error remains the same. A
non-XML MARC21 version of the record is available from
https://aleph.nkp.cz/F/?func=direct&doc_number=000131796&local_base=AUT.)

To process the file I have used xsltproc
(http://xmlsoft.org/XSLT/xsltproc.html).

When trying to process the file (xsltproc MARC21slim2MADS.xsl
americke_romany.xml > output.xml), the following error message pops up:

"xsl:attribute: Cannot add attributes to an element if children have
been already added to the element."

Josh Stompro from the Evergreen ILS community has come up with a simple
solution to the issue:

"If I swap lines 1084 and 1085 then the error goes away and both the
genre(155) and related genre(755) show up in the transformed xml."

For more details and suggestions please see Evergreen ILS main mailing
list archives:

http://libmail.georgialibraries.org/pipermail/open-ils-general/2018-November/015441.html

Do you think this might be a bug in the stylesheet which could be fixed
in the official release of the stylesheet
(http://www.loc.gov/standards/marcxml/xslt/MARC21slim2MADS.xsl)?

Thank you in advance for considering the issue!

Best regards,

Linda Jansova
on behalf of the Czech Evergreen community
[log in to unmask]


Top of Message | Previous Page | Permalink

Advanced Options


Options

Error during command authentication.

Error - unable to initiate communication with LISTSERV (errno=111). The server is probably not started.

Log In

Log In

Get Password

Get Password


Subscribe or Unsubscribe

Subscribe or Unsubscribe


Archives

ATOM RSS1 RSS2



LISTSERV.LOC.GOV

CataList Email List Search Powered by the LISTSERV Email List Manager