> From: Ardie Bausenbach [mailto:[log in to unmask]]
> Sent: Wednesday, March 27, 2002 03:50 PM
> 1. Will most novice users be able to distinguish between "name" as
> creator (1XX or 7XX) and name as "subject" (6XX)? Perhaps the name
> element should be more explicitly identified (perhaps "creator")?
See my earlier posted comments on XLink's role attribute and how you
don't need multiple name elements.
> 2. For corporate names, should there be an "order" attribute for
> "component", or will reading components left-to-right be sufficient?
XML defines the order. It's not left-to-right or right-to-left. It's
the order in which the nodes are placed into the record. I guess you
could define this as left-to-right or top-to-bottom.
> 3. Your notes for "name" indicate that "flat names" are
> presumed to be
> "structured". Can I assume this means, for example, that you expect
> personal names to be entered in inverted order? I am not sure you can
> count on users entering names in the manner we are used to
> seeing in the
> controlled entries of bibliographic records. However, there
> needs to be
> some mechanism (perhaps a "filingName" element) to enable systems to
> create usable lists of names for browsing and collocation.
I agree that you cannot assume that names are inverted. This creates
a problem for browsing and collocation. Users may not understand what
they should put in a filingName element or worse put something bizarre.
MODS has the same problem Dublin Core has in this respect. Users do
understand the difference between forename and surname (family name).
So maybe what is needed is needed is additional markup under name. I
don't think you need to go to the extreme as AACR2 but maybe you have
two elements. <forname> and <surname> with some guidelines for
converting AACR2 names into those parts.
> 4. Without knowing the MARC format meaning of 852, I would
> have assumed
> "location" dealt with some sort of geographic name rather than the
> institution holding the content (852ab) or the "shelving
> location" of the
> content (852j). Should this element also have a clearer name
I'm not sure holdingLocation would be anymore clearer. Users might
be more inclined to understand "documentLocation".