> Date: Thu, 16 Dec 2004 07:37:53 -0500
> From: Eliot Christian <[log in to unmask]>
>>> cql.anyField ? I don't like cql.record as a name, as to me that
>>> would imply that a string search should be matched against the
>>> entire record, rather than any subfield within the record.
>> Agreed -- your name is better,
> I get a sense that this discussion crossed over the "abstraction
> layer" line. On the search side of things, the abstraction should
> not reference "fields" but "indexes".
Usually, yes; this is a special-case index that Adlib want _precisely_
because, in this case, they really do want to talk about the contents
of the physical record rather than what is indexed where.
> cql.anyIndex might be better (assuming the semantics of it makes
> clear its distinction from cql.anywhere).
I don't see what cql.anyIndex might mean that would be different from
In any case, the point of this "index" is to search _the whole
/o ) \/ Mike Taylor <[log in to unmask]> http://www.miketaylor.org.uk
)_v__/\ "Yes, times change, but still God warns: ``You shall not
take a life''" -- Keith Green, "A Billion Starving People"
Listen to free demos of soundtrack music for film, TV and radio