> Wouldn't this be better in ServerInfo than in DatabaseInfo?
Possibly, but DatabaseInfo is a supposed to be for information about the
service as well as some minimal information about Collection to get by on
if there isn't a full collection description available.
ServerInfo on the other hand is the essential information you need to
connect to the server itself, eg host, port, URL and protocol.
In a (still hypothetical) version 3.0 we could rename them as:
serverInfo --> networkInfo
databaseInfo --> serviceInfo
Which would be more accurate. The one thing that I don't want to do is
cast off absolutely all of the collection description information -- at
least we need a title and a very generic description field, because while
this would be duplicated in a collection description, it would make the
ZeeRex record close to non-useful in terms of displaying a summary
,'/:. Dr Robert Sanderson ([log in to unmask])
,'--/::(@)::. Dept. of Computer Science, Room 805
,'---/::::::::::. University of Liverpool
____/:::::::::::::. L5R Shop: http://www.cardsnotwords.com/
I L L U M I N A T I