Print

Print


My bet is that the problem has something to do with the records to be
returned and not the request parameters themselves.

Have you tried a different query?  It might be just a problem with a
particular record.

Could you send me the complete stack trace?  That might help track down the
problem.

Thanks!

Ralph

> -----Original Message-----
> From: David Gilks [mailto:[log in to unmask]]
> Sent: Wednesday, June 25, 2003 10:45 AM
> To: [log in to unmask]
> Cc: [log in to unmask]
> Subject: problem setting SRW client params with SOAP::Lite
>
>
> Hi,
>
> I'm stuck on a problem setting up a SRW client request, which I hope
> somebody can help me with.
>
> The code below gets an error(see below) returned from the
> server. I have
> determined that the problem is in setting the 'startRecord' and
> 'maximumRecords', as if I comment these lines out I get a
> valid response but
> no results returned, only the number of hits the search
> matched is returned.
>
> Any ideas or help would be much appreciated.
>
> David Gilks
>
> ===============
> my $soap = SOAP::Lite
>
> ->service('http://alcme.oclc.org/axis/SOAR/services/SearchRetr
> ieveService
> ?wsdl')
>    ->outputxml(1)
>
> ->proxy('http://alcme.oclc.org/axis/SOAR/services/SearchRetrie
> veService')
> ;
>
> my $method = SOAP::Data->name('searchRetrieveRequest')
>   -> attr({xmlns => 'http://www.imsglobal.org/xsd/imsmd_rootv1p2'})
>   -> attr({xmlns => 'http://www.loc.gov/zing/srw/v1.0/'});
>
> my @params = (
>    SOAP::Data->name(query => 'lom.keyword scr software or computer'),
>    SOAP::Data->name(startRecord => '1'),
>    SOAP::Data->name(maximumRecords => '2')
> );
>
> my $response = $soap->call($method => @params);
>
> ================
> the error from the server is :
>  'ns1:Server.userException 'java.lang.IllegalArgumentException:
> java.lang.ClassCastException@b64078 server ....'
>