Print

Print


Thank you to Ray Denenberg and Justin Littman for explaining. The issue
is resolved as of today, but if it happens again, I'll look into whether
we're having any issue with w3 access. Another stopgap measure that
seemed to work for us yesterday was to take the version number out of
our MODS namespace location and reference the MODS 3.1, rather than 3.2,
schema. 

Best
Shifra

--
Shifra Pride Raffel
Web Archiving Programmer
California Digital Library
415 Twentieth St., 4th Floor
Oakland, CA 94612-2901 
http://cdlib.org
[log in to unmask] 
(510) 287-3833

> -----Original Message-----
> From: Metadata Object Description Schema List 
> [mailto:[log in to unmask]] On Behalf Of Ray Denenberg, Library of Congress
> Sent: Wednesday, January 10, 2007 6:27 AM
> To: [log in to unmask]
> Subject: Re: [MODS] Error validating MODS 3
> 
> As a stopgap measure, we've put xml.xsd up on the LC server:
> 
> http://www.loc.gov/standards/mods/xml.xsd
> 
> So if you can validate via local copy (copy the MODS schema 
> to your local system), change the line
> 
> <xsd:import namespace="http://www.w3.org/XML/1998/namespace"
> schemaLocation="http://www.w3.org/2001/xml.xsd"/>
> 
> to
> 
> <xsd:import namespace="http://www.w3.org/XML/1998/namespace"
> schemaLocation="http://www.loc.gov/standards/mods/xml.xsd"/>
> 
> And we'll look at this further (trying to see if we really 
> need to retain that import).
> Ray Denenberg
> 
> --Ray
> 
> 
> ----- Original Message -----
> From: "Shifra Raffel" <[log in to unmask]>
> To: <[log in to unmask]>
> Sent: Tuesday, January 09, 2007 7:15 PM
> Subject: [MODS] Error validating MODS 3
> 
> 
> As of just today, I'm receiving the following error even when 
> validating
> MODS that used to pass schema validation. Can anyone point me in the
> right direction to fix this?
> 
> SystemID: http://www.loc.gov/standards/mods/v3/mods-3-2.xsd Location:
> 4:111 Description: W schema_reference.4: Failed to read 
> schema document
> 'http://www.w3.org/2001/xml.xsd', because 1) could not find the
> document; 2) the document could not be read; 3) the root 
> element of the
> document is not <xsd:schema>. URL:
> http://www.w3.org/TR/xmlschema-1/#schema_reference
> SystemID: http://www.loc.gov/standards/mods/v3/mods-3-2.xsd Location:
> 1096:48 Description: E src-resolve: Cannot resolve the name 'xml:lang'
> to a(n) 'attribute declaration' component. URL:
> http://www.w3.org/TR/xmlschema-1/#src-resolve
> SystemID: http://www.loc.gov/standards/mods/v3/mods-3-2.xsd Location:
> 1096:48 Description: E s4s-elt-must-match.1: The content of 'language'
> must match (annotation?, ((attribute | attributeGroup)*,
> anyAttribute?)). A problem was found starting at: attribute.
> 
> Thanks,
> Shifra
> 
> --
> Shifra Pride Raffel
> Web Archiving Programmer
> California Digital Library
> 415 Twentieth St., 4th Floor
> Oakland, CA 94612-2901
> http://cdlib.org
> [log in to unmask]
> (510) 287-3833
>