Print

Print


Over the past week I have been looking at possibilities of embedding an
EAD document using the new schema in a METS document for descriptive
metadata, but doing so seems to generate errors with the EAD schema
itself. I have validated the EAD document outside of the METS instance
in Oxygen without getting any errors, and have validated the EAD schema
without problems, but the errors still keep popping up.

There are four types of errors presented. The first two come together
and take the form:

SystemID: http://www.loc.gov/ead/ead.xsd
Location: 2723:41
Description: src-resolve: Cannot resolve the name 'xlink:type1' to a(n)
'attribute group' component.
URL: http://www.w3.org/TR/xmlschema-1/#src-resolve

SystemID: http://www.loc.gov/ead/ead.xsd
Location: 2723:41
Description: s4s-elt-must-match.1: The content of 'extendedType' must
match (annotation?, ((attribute | attributeGroup)*, anyAttribute?)). A
problem was found starting at: attributeGroup.

The second pairs take the form:

SystemID: http://www.loc.gov/ead/ead.xsd
Location: 2796:41
Description: src-resolve: Cannot resolve the name 'xlink:type4' to a(n)
'attribute group' component.
URL: http://www.w3.org/TR/xmlschema-1/#src-resolve

SystemID: http://www.loc.gov/ead/ead.xsd
Location: 2796:41
Description: s4s-elt-invalid-content.1: The content of 'arc' is invalid.
Element 'attributeGroup' is invalid, misplaced, or occurs too often.

Is there anyone working with EAD documents embedded in an xmlData tag
who might know what is going on with this? Is it just because of the
XLink references in the EAD schema? And should I worry about the
validation errors or not?

I am new to METS and would appreciate any guidance anyone could give.

Thank you,

Cory Nimer
Manuscripts Cataloger/Metadata Specialist
Brigham Young University
1108 HBLL
(801) 422-6091