Print

Print


Hi Bill,

 

Are you including the proper doctype with your html output?  

 

For instance, something like this:

 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

 

<html xmlns:fn="http://www.w3.org/2005/02/xpath-functions"
xmlns:xdt="http://www.w3.org/2005/02/xpath-datatypes"
xmlns="http://www.w3.org/1999/xhtml"
xmlns:xs="http://www.w3.org/2001/XMLSchema"
xmlns:xlink="http://www.w3.org/1999/xlink"
xmlns:ead="urn:isbn:1-931666-22-9">

 

   <head>

      <title>Guide to a Collection</title>

      <link rel="stylesheet" type="text/css" href="eadStyle.css"/>

   </head>

<body>

<h1>EAD</h1>

</body>

</html>

 

should validate fine.

 

And for this, you would still use something like <xsl:output
method="html">

 

Does that work for you?

 

Mark Custer

 

 

 

From: Encoded Archival Description List [mailto:[log in to unmask]] On Behalf
Of Bill Walker
Sent: Tuesday, September 09, 2008 12:04 PM
To: [log in to unmask]
Subject: EAD 2 XHTML

 

I am attempting to transform EAD to XHTML.  My XSL stylesheet
<xsl:stylesheet> element has several namespaces which get output as
attribute to the opening <html> element.  

 

Here is my opening stylesheet element: 

 

<xsl:stylesheet version="2.0"
xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
xmlns:ead="urn:isbn:1-931666-22-9"
            xmlns:xs="http://www.w3.org/2001/XMLSchema"
xmlns="http://www.w3.org/1999/xhtml"
xmlns:fn="http://www.w3.org/2005/02/xpath-functions"
            xmlns:xdt="http://www.w3.org/2005/02/xpath-datatypes"
xmlns:xlink="http://www.w3.org/1999/xlink">

 

 

Here is the resulting HTML element:  

 

<html xmlns:fn="http://www.w3.org/2005/02/xpath-functions"
xmlns:xdt="http://www.w3.org/2005/02/xpath-datatypes"
xmlns="http://www.w3.org/1999/xhtml"
xmlns:xs="http://www.w3.org/2001/XMLSchema"
xmlns:xlink="http://www.w3.org/1999/xlink"
xmlns:ead="urn:isbn:1-931666-22-9">

 

 

Here is my <xsl:output> element:

 

 

Of course, these namespace attributes are not valid for the <html>
element, but are required for <xsl:stylesheet>.

 

How do I resolve this problem?

 

Bill Walker

Imaging Field Services Officer

Amigos Library Services, 

14400 Midway Road, 

Dallas, TX 75244-3509

800-843-8482 x2853

972-340-2853 (direct)

972-991-6061 (fax)

Email: [log in to unmask] 

Web: www.amigos.org