Either way, both are in the same namespace. "eac.staatsbibliothek-berlin.de" is quite a prefix however! It is the mapping to the URI that declares the namespace, not the prefix (or lack thereof in the default 'xmlns="http://eac.staatsbibliothek-berlin.de"'). I rather suspect that Michael is right, that a hand crafted document instance would better identify Michelle's issues. Hard to say without the software to hand, but there is nothing wayward about either of the schemas.

St.

Stephen Yearl
Library Digital Projects Officer
Boole Library
University College Cork
Ireland
+353 (0)21 420-5107 (work)
+353 (0)85 715-3952 (cell/mobile)
[log in to unmask]@gmail.com
   



-----Original Message-----
From: Encoded Archival Description List on behalf of Daniel Pitti
Sent: Tue 8/25/2009 7:15 PM
To: [log in to unmask]
Subject: Re: [EACWG] FW: EAC schema and XMetaL

The xmlns generated by XMetal is rather odd in that it supplies a 
prefix that duplicates the actual namespace. The schema declares the 
namespace as follows:

xmlns="http://eac.staatsbibliothek-berlin.de"

and NOT

xmlns:eac.staatsbibliothek-berlin.de="http://eac.staatsbibliothek-berlin.de
"


You might check XMetal documentation to see if there is an option for 
how the namespace is generated from the schema declaration. Perhaps it 
will allow you to change this behavior.

Daniel


On Aug 25, 2009, at 11:41 AM, Michele R Combs wrote:

> It isn't my xmlns declaration -- the declaration is automatically 
> being generated by XMetaL from the schema when I create a new XML 
> document.  The schema I'm using is the one on the draft page that 
> was announced last week (I downloaded it from there).  I'd prefer to 
> alter the schema so that I don't have to manually change the 
> document each time I create one.   Can I do that without making the 
> schema wrong/invalid?  If so, how do I do it?
>
> Michele
>
> ________________________________________
> From: Encoded Archival Description List [[log in to unmask]] On Behalf Of 
> Daniel Pitti [[log in to unmask]]
> Sent: Tuesday, August 25, 2009 7:08 AM
> To: [log in to unmask]
> Subject: Fwd: [EACWG] FW: EAC schema and XMetaL
>
> On behalf of Basil Dewhurst (National Library of Australia).
>
> Begin forwarded message:
>
> [...]
>
>
> The problem is in Michele's xmlns declaration 
> xmlns:eac.staatsbibliothek-berlin.de="http://eac.staatsbibliothek-berlin.de
> ".  The fix would be to use xmlns="http://eac.staatsbibliothek-berlin.de
> " if you want http://eac.staatsbibliothek-berlin.de to be the 
> default namespace for the xml document.  This means your eac 
> document would look like this:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <eac-cpf xmlns="http://eac.staatsbibliothek-berlin.de"
>   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>   xsi:schemaLocation="http://eac.staatsbibliothek-berlin.de http://www3.iath.virginia.edu/eac/cpf/schema/cpf.xsd
> ">