Print

Print


Jens -  can you send me the file that doesn't validate.

The following validates with XMLSpy

_____________________________________
<mods 

      xmlns="http://www.loc.gov/mods/v3" 
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
      xsi:schemaLocation="http://www.loc.gov/mods/v3 mods-3-4.xsd" 
      xmlns:xlink="http://www.w3.org/1999/xlink">

 <abstract  xlink:href="http:xxx"/>

</mods>
____________________________________


(I have a minor temporary problem with my Oxygen license, and I would like
look at your file with XMLSpy before I pursue the license problem.)

--Ray



> -----Original Message-----
> From: Metadata Object Description Schema List
> [mailto:[log in to unmask]] On Behalf Of Jens Østergaard Petersen
> Sent: Tuesday, October 11, 2011 2:33 AM
> To: [log in to unmask]
> Subject: Re: [MODS] xlink namespace in MODS schema
> 
> Hello Ray,
> 
> Sorry for casting aspersions on Saxon …. it turned out that an outdated
> XLink schema included with oXygen was the culprit.
> 
> <http://www.oxygenxml.com/pipermail/oxygen-user/2011-
> October/003867.html>
> 
> However, there remains a small issue.
> 
> The MODS XLink schema <http://www.loc.gov/standards/xlink/xlink.xsd> is
> derived from (identical to) the METS XLink schema. This schema maps the
> namespace to "http://www.w3.org/1999/xlink". Most naturally, this would
> refer to <http://www.w3.org/1999/xlink.xsd> (which is identical in
> substance to <http://www.w3.org/XML/2008/06/xlink.xsd>), however, what
> Library of Congress calls "simpleLink", W3C here calls "simpleAttrs" -
> "simpleLink" comes from <http://www.w3.org/TR/xlink/>. This means that
> a valid MODS record employing @xlink:href does not validate against the
> current XLink schema.
> 
> I have not looked for any other differences.
> 
> Best,
> 
> Jens
> 
> On Oct 7, 2011, at 2:33 PM, Jens Østergaard Petersen wrote:
> 
> > Hello Ray,
> >
> > Thank you for answering so quickly.
> >
> > It appears to be the case that my problem is connected to a possible
> > bug in how Saxon validates; see
> >
> > <http://www.oxygenxml.com/pipermail/oxygen-user/2011-
> October/003865.ht
> > ml>
> > <http://www.oxygenxml.com/pipermail/oxygen-user/2011-
> October/003866.ht
> > ml>
> >
> > Sorry for the static! I think it is often the case that formulating a
> question on a mailing list leads to a more systematic investigation of
> possible answers - which then renders the question unnecessary ….
> >
> > Best,
> >
> > Jens
> >
> > On Oct 6, 2011, at 3:18 PM, Ray Denenberg, Library of Congress wrote:
> >
> >> Could you send me the XML file please.  --Ray
> >>
> >>> -----Original Message-----
> >>> From: Metadata Object Description Schema List
> >>> [mailto:[log in to unmask]] On Behalf Of Jens Østergaard
> Petersen
> >>> Sent: Thursday, October 06, 2011 4:25 AM
> >>> To: [log in to unmask]
> >>> Subject: [MODS] xlink namespace in MODS schema
> >>>
> >>> Hello,
> >>>
> >>> I am probably just missing something obvious, but how do I redefine
> >>> the MODS 3.4 schema to make use of @xlink:href valid?
> >>>
> >>> Engine name: Saxon-EE 9.3.0.5
> >>> Severity: fatal
> >>> Description: The attributeGroup {simpleLink} is referenced, but has
> >>> not been declared
> >>>
> >>> Best,
> >>>
> >>> Jens=
> >