Hi David,

Back at it some more.

So we went back to Ubuntu 12.10

1. Followed exact apt-get install instructions.
2. Tested Apache - worked
3. Tested Jetty - worked (after editing the /etc/default/jetty file to put Nostart correct
4. Followed exact Get Chronam instructions
5. Followed exact Configure Solr instructions
6. service jetty start command returns Starting Jetty: FAILED

Luckily remembered this time to make copies of original /etc/default/jetty and /etc/init.d/jetty files

7. Replaced "new" /etc/default/jetty with original.
8. Started Jetty - says it started but not correctly
9. Put "new" /etc/default/jetty (/opt/chronam/conf/jetty-ubuntu) back
10. Replaced "new" /etc/init.d/jetty with original
11. Started Jetty - gives the correct "*Starting Jetty servlet engine. jetty..." information.
12. Can access jetty in browser
13. Solr fails - "404 Error - Problem accessing /solr. Reason: NOT_FOUND"

I have witnesses that will swear we had this running at one point. We are following the instructions exactly.

What's next?



From: David Brunton <[log in to unmask]>
To: [log in to unmask]
Sent: Tuesday, September 17, 2013 7:26 PM
Subject: Re: Jetty failed

Hi Glenn,

We haven't tested here using Ubuntu 13.04 (12.10 only so far), but you should be able to execute these instructions anywhere besides /opt (like in your home directory, or from /opt/chronam).  Can you tell us what's in the jetty log?  It should be in /opt/solr-4.3.1/logs/ if it was able to write there.

Best,
David.


On Tue, Sep 17, 2013 at 5:58 PM, Glenn Bunton <[log in to unmask]> wrote:
At it once again.

All instructions from install_ubuntu.md followed down to "service jetty start".  Returns

Starting Jetty: Failed

Tested jetty prior to solr install and it worked.

Question:

Where should I be when I carry out these instructions?

wget http://archive.apache.org/dist/lucene/solr/4.3.1/solr-4.3.1.tgz
tar zxvf solr-4.3.1.tgz
sudo mv solr-4.3.1/example/ /opt/solr-4.3.1
Obvioulsy not in /opt or I overwrite what's already there. Does it matter where I uncompress/untar?

Any ideas why jetty is failing to start?

ubuntu 13.04
Have had it working before this newest install